pcwPDF2HTML 0.1

PDF-Dateien nach HTML exportieren

Thorsten Eggeling

Version 0.1 (draft) 2004-10-01

Copyright © 2004 Thorsten Eggeling

License

http://www.gnu.org/licenses/fdl.html

Abstract

Dieses Dokument beschreibt die wichtigsten Funktion von pcwPDF2HTML 1.0.

Inhaltsverzeichnis

(De)Installation
Export-Optionen
Weitere Optionen
Bedienung
Lizenz


(De)Installation

Starten Sie das Setup-Programm und folgen Sie den Anweisungen auf dem Bildschirm. Beachten Sie, das pcwPDF2HTML Schreibzugriff im Installationsordner benötigt.

Die De-Installation erfolgt wir üblich über "Systemsteuerung, Software". Sie können aber auch "Start, Programme, PC-WELT, pcwPDF2HTML, pcwPDF2HTML entfernen" verwenden.


Export-Optionen

pcwPDF2HTML steuert das Kommandozeilen-Tool PDFToHTML ( http://pdftohtml.sourceforge.net ). Die einstellbaren Optionen entsprechen daher den Schaltern dieses Tools.

Standardmäßig konvertiert das Tool PDF-Dokumente im einfachen Modus (keine Option ist gesetzt). Besondere Layouts werden dabei nicht berücksichtigt. Es ergibt sich ein Fließtext, Bilder werden in das JPEG-Format konvertiert. Die Ausgabe erfolgt in den Ordner, in dem auch das Quell-Dokument liegt. Der Name des erzeugten Dokuments entspricht dem Originalnamen mit angehängtem "html".

1. "Seiten von bis": Mit dieser Option beschränken Sie die zu konvertierenden Seiten.

2. "komplexe Dokumente": Verwenden Sie diese Option, wenn Sie Dokumente mit komplexen Layouts konvertieren möchten, beispielsweise Dokumente mit mehreren Spalten und Bildern.

3. "keine Frames": Standardmäßig erzeugt das Tool ein HTML-Framedokument mit einer Navigation auf der linken Seite. Ist diese Option aktiv, entsteht nur ein Dokument.

4. "keine Bilder": Bilder werden nicht extrahiert.

5. "versteckten Text ausgeben": Versteckten Text mit ausgeben.

6. "mit Unterverzeichnissen": Wenn Sie einen Ordner mit Quelldokumenten angeben, konvertiert das Tool auch alle gefundenen Dokumente aus den Unterverzeichnissen.

7. ".pdf links durch .html" ersetzen": Enthält eine Dokument einen Link auf eine PDF-Datei, ersetzt das Tool diesen durch einen Link auf eine HTML-Datei mit dem gleichen Namen.

8. "Absätze nicht verbinden": Standardmäßig verbindet das Tool Ansätze miteinander. Ist diese Option aktiv bleiben Absätze getrennt.

9. "Zoom Faktor": Standardmäßig werden die Dokumente um den Faktor 1,5 vergrößert. Sie können hier bei Bedarf einen größeren oder kleineren Wert eingeben.

10. "XML statt HTML erzeugen": Das Tool konvertiert PDF nach XML statt nach HTML.

11. "nur markierte Dokumente": Standardmäßig verarbeitet das Tool alle Dokumente aus der Liste. Ist diese Option aktive, konvertiert es nur das gerade markierte Dokument.

12. "Text-Encoding": Standard ist "Latin1". Mögliche Werte sind ASCII7, Symbol, ZapfDingbats, UTF-8, UCS-2. Achtung: Groß-/Kleinschreibung werden unterschieden.

13. "GS-Device": Gilt nur in Verbindung mit "komplexe Dokumente". Standardmäßig erzeugt das Tool PNG-Dateien. Sie können hier aber beispielsweise auch "jpeg" eintragen.

14. "Ausgabe in": Wählen Sie hier bei Bedarf einen Ordner, in dem Sie die konvertieten Dateien ablegen möchten.

15. "Neuer Ordner für jede Datei": Gilt nur in Verbindung mit "Ausgabe in". Das Tool legt beim Konvertieren mehrerer Dateien einen eigenen Ordner für jedes Dokument an.


Weitere Optionen

Nach einem Klick auf "Optionen sehen Sie den abgebildeten Dialog. Hier können Sie für Kennwortgeschützte PDF-Dokumente das Besitzer oder Anwender-Kennwort eingeben. Das gleiche Kennwort gilt für alle Dokumente, die Sie konvertieren.

Standardmäßig bringt pcwPDF2HTML sein eigenen Ghostscript und PDFToHTML mit. Diese liegen in den entsprechenden Unterordnern. Sie können die Programme aber auch aus einem anderen Verzeichnis verwenden. Geben Sie in diesem Fall den Pfad zu den ausführbaren Dateien an.


Bedienung

Über die Schaltfläche "Hinzufügen" fügen Sie den kompletten Pfad zu den PDF-Dokumente in die Liste ein. Endet der Pfad mit "*.pdf", verarbeitet das Tool alle PDF-Dateien aus aus diesem Ordner. Ist die Option "mit Unterverzeichnissen" aktiv, werden auch die Dateien aus allen Unterverzeichnissen berücksichtigt.

Sie können Dateien und Ordner auch per Drag & Drop vom Windows Explorer auf die Liste ziehen.

Über die Schaltfläche "Löschen" entfernen Sie den gerade markierten Eintrag aus der Liste. Mit "Alle Löschen" entfernen Sie alle Einträge.

Mit einem Klick auf "Konvertieren" starten Sie die Umwandlung. Nach einem Klick auf "Log anzeigen" sehen Sie bei Bedarf die Ausgaben der Kommandozeilen-Tools.

Mit "Abbrechen" stoppen Sie den Export. Sie müssen dann warten, bis das Programm den gerade laufenden Export beendet hat. Das gleiche gilt, wenn Sie das Programm beenden.


Lizenz

pcwPDF2HTML 0.1 ist freie Software. Sie können es unter den Bedingungen der GNU General Public License, wie von der Free Software Foundation veröffentlicht, weitergeben und/oder modifizieren, entweder gemäß Version 2 der Lizenz oder (nach Ihrer Option) jeder späteren Version.

Die Veröffentlichung dieses Programms erfolgt in der Hoffnung, daß es Ihnen von Nutzen sein wird, aber OHNE IRGENDEINE GARANTIE, sogar ohne die implizite Garantie der MARKTREIFE oder der VERWENDBARKEIT FÜR EINEN BESTIMMTEN ZWECK. Details finden Sie in der GNU General Public License.

Download des Programms über http://www.pcwelt.de.

Bei Problemen mit der Software und für Verbesserungsvorschläge steht Ihnen unser Forum zur Verfügung.